Jump to content
joshsr12345

Dubia roach colony problem.

Recommended Posts

Hello everyone i have recently just started up a dubia colony of 150 Females 30 males and 200 nymphs. within the first week i have had 10 or so die off. when they die they are just going on there backs and for a few hours sometimes even a day they are just laying there wiggling there little legs then they just give out. as for the females when they have been dieing they are leaving a little bit of white...bubble? coming out of there backside. also when some of them die they are squirting liquid out which i guess is there insides. the death rate has slowed by a lot now but i'm still worried i don't want my whole colony dieing. so far i have them in a 75g wide tank they have drink carriers as there cardboard flats. i am using Water gel crystals. ground up dog food and oranges or apples as there veggies. the temp is 86 most of the time and humidity is around 60-70 can anyone think what may be going wrong and why? maybe some are just stressed from the trip? o and also i am finding like 7 so far of those egg tube things laying on the ground why would the female be dropping those? thanks in advance

Share this post


Link to post
Share on other sites

Maybe the ones that are dying are due to old age.

As for the white thing/bubble coming out, I also don't know that.

The egg tube things are aborted oothecas.

The females are suppose to be inserting those again back to their abdomen so that they would give live birth in a few months.

Share this post


Link to post
Share on other sites

Maybe the ones that are dying are due to old age.

As for the white thing/bubble coming out, I also don't know that.

The egg tube things are aborted oothecas.

The females are suppose to be inserting those again back to their abdomen so that they would give live birth in a few months.

the person who sold me them said they are not very old. so im not sure about that one.

heres a picture of the white thing

HPIM1983.jpg

HPIM1985.jpg

(there is a female laying on her back today also who is just wiggling her legs but when i flip her over she dosent do anything) which is normaly how i have seen them start to die

any clue why they are dropping them? i also found 2 more today and about 6 more adults dead (the babys seem to be ok only found a few so far) it has been a few days since i checked and some of those dead look like they have been so since then. they also all seem to want to stay on the bottom of the tank under the holders (well not all of them but alot of them do) not really sure why but the babys seem to be all over. thanks in advance again! really dont want them deing off

Share this post


Link to post
Share on other sites

Sounds normal to me, at least for a larger colony.

The blobs coming out of the females are the brood sack, which normally carries the eggs. For whatever reason (maybe humidity?) it seems like when the females ditch their oothecae the brood sack is also going out with it and not being retracted.

Maybe mist a little more.

Share this post


Link to post
Share on other sites

so far about 30 dead the babys seem to be doing fine however and one of my adults died mid molt today butmy humidity is about 60-80% normally. so not really sure whats going on :( also should i continue to remove the dead ones or just leave them in there untill my cleaings? dont want to disturb the colony to much.

any reason for the dropped egg sacs? thanks in advance!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×